aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteffan Karger2016-08-15 20:02:36 +0200
committerDavid Sommerseth2016-08-25 19:58:33 +0200
commitee4f37c3533667aee87fd39ba131e80f3c1cfde7 (patch)
tree0f6dd7d0bb4057cf3a852d6973c02365c07be089 /configure.ac
parent8cba9ffc57739eefa8e56b0738acd1dee2ff2396 (diff)
downloadopenvpn-ee4f37c3533667aee87fd39ba131e80f3c1cfde7.zip
openvpn-ee4f37c3533667aee87fd39ba131e80f3c1cfde7.tar.gz
Fix unittests for out-of-source builds
Signed-off-by: Steffan Karger <steffan@karger.me> Acked-by: Matthias Andree <matthias.andree@gmx.de> Message-Id: 1471284156-2324-1-git-send-email-steffan@karger.me URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg00027.html Signed-off-by: David Sommerseth <davids@openvpn.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4f14ebd..9189c94 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1215,7 +1215,7 @@ AC_SUBST([TEST_CFLAGS])
# needed for unit testing
AC_CHECK_PROGS([CMAKE], [cmake])
if test -n "${CMAKE}"; then
- if test -f vendor/cmocka/CMakeLists.txt; then
+ if test -f "${srcdir}/vendor/cmocka/CMakeLists.txt"; then
AM_CONDITIONAL([CMOCKA_INITIALIZED], [true])
else
AM_CONDITIONAL([CMOCKA_INITIALIZED], [false])