aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSelva Nair2023-02-07 19:59:25 -0500
committerGert Doering2023-02-10 22:02:18 +0100
commite3ad1fc4230fb3a08b484e76ce0a31f2479d3c8f (patch)
treee8020bb0d229fb449e8bc4c5a17ce4cd386f647a /configure.ac
parente80720ef9399d7a4e3469cf1004d064643e0f4dd (diff)
downloadopenvpn-e3ad1fc4230fb3a08b484e76ce0a31f2479d3c8f.zip
openvpn-e3ad1fc4230fb3a08b484e76ce0a31f2479d3c8f.tar.gz
Build unit tests in mingw Windows build
- Minor changes to the build system to include some dependencies for Windows build - test_tls_crypt not built as it will pull in win32.c and its dependencies - If cross-compiling, "make check" will only build the tests but not run any. Copy to Windows and run manually. Executables are in <buid-dir>/tests/unit_tests/openvpn/.libs/ and these depend on cmocka.dll in addition to openssl libs that some tests link to. Building with mingw on Windows should run the tests (untested). v2: networking_testdriver was mistakenly enabled to run, while originally it was only set to build. Corrected. v3: exclude check_engine_keys.sh when cross-compiling As suggested by Arne Schwabe <arne@rfc2549.org> Signed-off-by: Selva Nair <selva.nair@gmail.com> Acked-by: Arne Schwabe <arne@rfc2549.org> Message-Id: <20230208005925.393200-1-selva.nair@gmail.com> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg26188.html Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 95d795c..66ba6f3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,6 +364,8 @@ case "$host" in
;;
esac
+AM_CONDITIONAL([CROSS_COMPILING], test "${cross_compiling}" = "yes")
+
PKG_PROG_PKG_CONFIG
AC_PROG_CPP
AC_PROG_INSTALL