aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGert Doering2016-06-09 15:00:32 +0200
committerGert Doering2016-06-09 15:07:34 +0200
commitd16072cf17ce8debcf796565841a54f1253a9923 (patch)
tree5b43d76254deafdfc8821fbbd8467d7ca4182706 /configure.ac
parent46e4b6639a950c56a08261b6610e7fe17404213d (diff)
downloadopenvpn-d16072cf17ce8debcf796565841a54f1253a9923.zip
openvpn-d16072cf17ce8debcf796565841a54f1253a9923.tar.gz
Change --enable-pedantic to use -std=c99 and not -ansi (C90).
There's quite a bit of our code that fails compilation with "gcc -pedantic -ansi" and should not be changed - like, LZ4 using "long long" variables which C90 does not have. Be pragmatic. trac #616 Signed-off-by: Gert Doering <gert@greenie.muc.de> Acked-by: Gert Doering <gert@greenie.muc.de> Message-Id: <1465477232-25826-1-git-send-email-gert@greenie.muc.de> URL: http://article.gmane.org/gmane.network.openvpn.devel/11882 Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d733023..4f14ebd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1128,7 +1128,7 @@ fi
if test "${enable_pedantic}" = "yes"; then
enable_strict="yes"
CFLAGS="${CFLAGS} -pedantic"
- test "${WIN32}" != "yes" && CFLAGS="${CFLAGS} -ansi"
+ test "${WIN32}" != "yes" && CFLAGS="${CFLAGS} -std=c99"
fi
if test "${enable_strict}" = "yes"; then
CFLAGS="${CFLAGS} -Wall -Wno-unused-parameter -Wno-unused-function"