aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmmanuel Deloget2017-06-12 15:43:26 +0200
committerGert Doering2017-06-18 12:15:04 +0200
commitc07c0358b553c519ed9d80e2e0a9ba48ca8850e4 (patch)
tree23d54e3b9ae3c5b469ebbf0484204a0294e14616 /configure.ac
parentf7780af6f1aaffcbbfb8b4dde0f2af052f84b28a (diff)
downloadopenvpn-c07c0358b553c519ed9d80e2e0a9ba48ca8850e4.zip
openvpn-c07c0358b553c519ed9d80e2e0a9ba48ca8850e4.tar.gz
OpenSSL: don't use direct access to the internal of DSA
OpenSSL 1.1 does not allow us to directly access the internal of any data type, including DSA. We have to use the defined functions to do so. Compatibility with OpenSSL 1.0 is kept by defining the corresponding functions when they are not found in the library. Signed-off-by: Emmanuel Deloget <logout@free.fr> Acked-by: Steffan Karger <steffan.karger@fox-it.com> Message-Id: <20170612134330.20971-5-logout@free.fr> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg14791.html Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e9ac5a6..5234878 100644
--- a/configure.ac
+++ b/configure.ac
@@ -932,6 +932,8 @@ if test "${enable_crypto}" = "yes" -a "${with_crypto_library}" = "openssl"; then
RSA_bits \
RSA_get0_key \
RSA_set0_key \
+ DSA_get0_pqg \
+ DSA_bits \
RSA_meth_new \
RSA_meth_free \
RSA_meth_set_pub_enc \