aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAntonio Quartulli2021-08-27 16:48:07 +0200
committerGert Doering2021-09-13 12:01:19 +0200
commitb61d1988582feb2e1ed1cf9e62700f484e0bc150 (patch)
tree54ffb5908d034de3afe65017095bab8153c00167 /configure.ac
parentd814581a9375713a0a4d70f751f84e750a5d661a (diff)
downloadopenvpn-b61d1988582feb2e1ed1cf9e62700f484e0bc150.zip
openvpn-b61d1988582feb2e1ed1cf9e62700f484e0bc150.tar.gz
configure: search also for rst2{man, html}.py
On some systems the rst2{man,html} executables may have a slightly different name, like rst2{man,html}.py. Add this name variation to the Generic Programs check. This specific variation is found on Gentoo Linux. Cc: David Sommerseth <davids@openvpn.net> Signed-off-by: Antonio Quartulli <a@unstable.cc> Acked-by: Gert Doering <gert@greenie.muc.de> Message-Id: <20210827144807.27004-1-a@unstable.cc> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg22777.html Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 5d37896..7c2ead6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -362,8 +362,8 @@ AC_DEFINE_UNQUOTED([SYSTEMD_ASK_PASSWORD_PATH], ["$SYSTEMD_ASK_PASSWORD"], [Path
#
AC_ARG_VAR([RST2MAN], [path to rst2man utility])
AC_ARG_VAR([RST2HTML], [path to rst2html utility])
-AC_CHECK_PROGS([RST2MAN], [rst2man])
-AC_CHECK_PROGS([RST2HTML], [rst2html])
+AC_CHECK_PROGS([RST2MAN], [rst2man rst2man.py])
+AC_CHECK_PROGS([RST2HTML], [rst2html rst2html.py])
AM_CONDITIONAL([HAVE_PYDOCUTILS], [test "${RST2MAN}" -a "${RST2HTML}"])
# Set -std=c99 unless user already specified a -std=