aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authororbea2023-09-09 06:49:56 -0700
committerGert Doering2023-09-10 16:46:28 +0200
commit34bf473e19118eecf525e7401ef37b1cbf661e67 (patch)
treecf40c315ae15a1142aad774d34c0297d589472e7 /configure.ac
parent5f910a42b86e90f1893a668ee280422b6587ada1 (diff)
downloadopenvpn-34bf473e19118eecf525e7401ef37b1cbf661e67.zip
openvpn-34bf473e19118eecf525e7401ef37b1cbf661e67.tar.gz
configure: disable engines if OPENSSL_NO_ENGINE is defined
Starting with LibreSSL 3.8.1 the engines have been removed which causes the OpenVPN build to fail. This can be solved during configure by checking if OPENSSL_NO_ENGINE is defined in opensslconf.h. Signed-off-by: orbea <orbea@riseup.net> Acked-by: Gert Doering <gert@greenie.muc.de> Message-Id: <20230909134956.5902-1-orbea@riseup.net> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg26994.html Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2f65cbd..266b66f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -927,11 +927,17 @@ if test "${with_crypto_library}" = "openssl"; then
[AC_LANG_PROGRAM(
[[
#include <openssl/opensslv.h>
+ #include <openssl/opensslconf.h>
]],
[[
/* Version encoding: MNNFFPPS - see opensslv.h for details */
#if OPENSSL_VERSION_NUMBER >= 0x30000000L
- #error Engine supported disabled by default in OpenSSL 3.0+
+ #error Engine support disabled by default in OpenSSL 3.0+
+ #endif
+
+ /* BoringSSL and LibreSSL >= 3.8.1 removed engine support */
+ #ifdef OPENSSL_NO_ENGINE
+ #error Engine support disabled in openssl/opensslconf.h
#endif
]]
)],