aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAntonio Quartulli2021-10-05 14:27:36 +0200
committerGert Doering2021-10-06 11:56:58 +0200
commit01ce6ca39d1f4bf45dcd49baede0094c4c990d3b (patch)
tree8e09f54692e944f6c891e765d0717434f741acca /configure.ac
parentaf5de933a0633436e0fe00c42464f4a7ab5ac509 (diff)
downloadopenvpn-01ce6ca39d1f4bf45dcd49baede0094c4c990d3b.zip
openvpn-01ce6ca39d1f4bf45dcd49baede0094c4c990d3b.tar.gz
configure: remove useless -Wno-* from default CFLAGS
Historically we always had -Wno-unused-parameter and -Wno-unused-function enabled along with -Wall. When we made -Wall a default option, we carried the other two along and made them default too (in 2018). Now the code is much cleaner compared to the past and we do not really require -Wno-unused-parameter and -Wno-unused-function anymore. Actually they may hide really unused functions that we'd need to cleanup. For this reason remove -Wno-unused-parameter and -Wno-unused-function for good from the default CFLAGS. Any new warning should rather be fixed than hidden. Signed-off-by: Antonio Quartulli <a@unstable.cc> Acked-by: Gert Doering <gert@greenie.muc.de> Message-Id: <20211005122736.4060-1-a@unstable.cc> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg22917.html Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 0 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7c2ead6..a37dc76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1224,8 +1224,6 @@ AC_DEFUN([ACL_CHECK_ADD_COMPILE_FLAGS], [
)
ACL_CHECK_ADD_COMPILE_FLAGS([-Wno-stringop-truncation])
-ACL_CHECK_ADD_COMPILE_FLAGS([-Wno-unused-function])
-ACL_CHECK_ADD_COMPILE_FLAGS([-Wno-unused-parameter])
ACL_CHECK_ADD_COMPILE_FLAGS([-Wall])
if test "${enable_pedantic}" = "yes"; then