aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Sommerseth2017-10-02 21:07:32 +0200
committerGert Doering2017-10-02 21:10:04 +0200
commite5b279f1b62e75569ee8d988b55e6ee0dc93464e (patch)
tree2144537023bea3dc1e44118adf5bdfe4efe08ffd /configure.ac
parentf91e4863bc138213a07a2cf53ad71d8a4532abef (diff)
downloadopenvpn-e5b279f1b62e75569ee8d988b55e6ee0dc93464e.zip
openvpn-e5b279f1b62e75569ee8d988b55e6ee0dc93464e.tar.gz
lz4: Fix broken builds when pkg-config is not present but system library is
In commit f91e4863bc1382 we fixed an issue where LZ4_LIBS could be overwritten in some situations. But on systems where lz4 is installed on the system but is lacking pkg-config information, the linker will not know about the lz4 library when completing the build. This fixes the issue by explicitly setting LZ4_LIBS to contain -llz4 if pkg-config test was run and failed verifying the installed lz4 version number. This also ensures that LZ4_LIBS will not be overwritten if it has been provided on the ./configure command line. Signed-off-by: David Sommerseth <davids@openvpn.net> Acked-by: Gert Doering <gert@greenie.muc.de> Message-Id: <20171002190732.12531-1-davids@openvpn.net> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg15549.html Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 394f5b0..6f59bae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1093,7 +1093,9 @@ if test "$enable_lz4" = "yes" && test "$enable_comp_stub" = "no"; then
PKG_CHECK_MODULES([LZ4],
[liblz4 >= 1.7.1 liblz4 < 100],
[have_lz4="yes"],
- [] # If this fails, we will do another test next
+ [LZ4_LIBS="-llz4"] # If this fails, we will do another test next.
+ # We also add set LZ4_LIBS otherwise the
+ # linker will not know about the lz4 library
)
fi