aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteffan Karger2017-07-20 13:39:00 +0200
committerGert Doering2017-07-20 14:18:07 +0200
commitfd2a29ab2668fea9c0ac972d5ec69f00232c88b6 (patch)
treed2637328c9c45e83380fbc1c6efedf5718e4b5ce /configure.ac
parentad7f7e56d34bbf477a7e5639f1b78b2c7e58186c (diff)
downloadopenvpn-fd2a29ab2668fea9c0ac972d5ec69f00232c88b6.zip
openvpn-fd2a29ab2668fea9c0ac972d5ec69f00232c88b6.tar.gz
Remove strerror_ts()
This function was only called in string format functions, which already copy the contents, so all this ever did was adding redundant malloc() and free() calls. Also, this wasn't as thread-safe as it claims: another thread could still change the string value between the strerror() and buf_printf() calls. So, instead of a not needed false sense of thread-safeness, just be honest and use strerror() directly. (I think we should find a better place for everything currently in misc.c, and get rid of it all together. In this case, the better place is /dev/null. This patch is part of that effort.) Signed-off-by: Steffan Karger <steffan@karger.me> Acked-by: Gert Doering <gert@greenie.muc.de> Message-Id: <1500550740-24773-1-git-send-email-steffan.karger@fox-it.com> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg15105.html Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 60bb465..39d992c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -662,7 +662,7 @@ AC_FUNC_FORK
AC_CHECK_FUNCS([ \
daemon chroot getpwnam setuid nice system getpid dup dup2 \
- getpass strerror syslog openlog mlockall getgrnam setgid \
+ getpass syslog openlog mlockall getgrnam setgid \
setgroups stat flock readv writev time gettimeofday \
ctime memset vsnprintf strdup \
setsid chdir putenv getpeername unlink \