aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSteffan Karger2018-10-28 15:54:49 +0100
committerDavid Sommerseth2019-04-17 22:04:53 +0200
commit4ded2deda0d6d33d38fbbd1f4cd4e9acc0836a89 (patch)
treee98d37ed116851faef9e9f5470e10fc219f7a123 /configure.ac
parent6206316275b14bd433a8651568f0185f4fa9f038 (diff)
downloadopenvpn-4ded2deda0d6d33d38fbbd1f4cd4e9acc0836a89.zip
openvpn-4ded2deda0d6d33d38fbbd1f4cd4e9acc0836a89.tar.gz
cmocka: use relative paths
Simplifies the build scripts, and fixes my CI, where paths on the test slave can be different from paths on the build slave. Signed-off-by: Steffan Karger <steffan@karger.me> Acked-by: David Sommerseth <davids@openvpn.net> Message-Id: <20181028145449.12676-1-steffan@karger.me> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg17849.html Signed-off-by: David Sommerseth <davids@openvpn.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 2 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 90fc904..59673e0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1353,15 +1353,8 @@ AC_SUBST([sampledir])
AC_SUBST([systemdunitdir])
AC_SUBST([tmpfilesdir])
-VENDOR_SRC_ROOT="\$(abs_top_srcdir)/vendor/"
-VENDOR_DIST_ROOT="\$(abs_top_builddir)/vendor/dist"
-VENDOR_BUILD_ROOT="\$(abs_top_builddir)/vendor/.build"
-AC_SUBST([VENDOR_SRC_ROOT])
-AC_SUBST([VENDOR_BUILD_ROOT])
-AC_SUBST([VENDOR_DIST_ROOT])
-
-TEST_LDFLAGS="${OPTIONAL_CRYPTO_LIBS} ${OPTIONAL_PKCS11_LIBS} ${OPTIONAL_LZO_LIBS} -lcmocka -L\$(abs_top_builddir)/vendor/dist/lib -Wl,-rpath,\$(abs_top_builddir)/vendor/dist/lib"
-TEST_CFLAGS="${OPTIONAL_CRYPTO_CFLAGS} ${OPTIONAL_PKCS11_CFLAGS} ${OPTIONAL_LZO_CFLAGS} -I\$(top_srcdir)/include -I\$(abs_top_builddir)/vendor/dist/include"
+TEST_LDFLAGS="${OPTIONAL_CRYPTO_LIBS} ${OPTIONAL_PKCS11_HELPER_LIBS} -lcmocka -L\$(top_builddir)/vendor/dist/lib -Wl,-rpath,\$(top_builddir)/vendor/dist/lib"
+TEST_CFLAGS="${OPTIONAL_CRYPTO_CFLAGS} ${OPTIONAL_PKCS11_HELPER_CFLAGS} -I\$(top_srcdir)/include -I\$(top_builddir)/vendor/dist/include"
AC_SUBST([TEST_LDFLAGS])
AC_SUBST([TEST_CFLAGS])