aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGert Doering2019-06-23 20:32:10 +0200
committerGert Doering2019-06-24 20:43:58 +0200
commit222e691739a111f5becbce39c4cceaa8fff3c284 (patch)
tree9f617c15c7f88fbcd1fe137898a33d67dad45f7c /Makefile.am
parentb3cfc43da3583ae8aa761beb29f016311b2ba64f (diff)
downloadopenvpn-222e691739a111f5becbce39c4cceaa8fff3c284.zip
openvpn-222e691739a111f5becbce39c4cceaa8fff3c284.tar.gz
Remove cmocka submodule, rely on system-wide installation instead.
We used to ship git submodule instructions to build a local copy of cmocka in vendor/cmocka/ and use that (if cmake is installed) to build unit tests. With the network test driver this turns out to be a LD_LIBRARY_PATH vs. SUDO complication which is really outweighing the benefit of a local build today - so, use the system-wide installation if available (querying pgk-config). Do not build unit-tests otherwise. v2: (inspired by patch from David Sommerseth) introduce "configure --disable-unit-test" switch simplify configure.ac logic use CMOCKA_LIBS and CMOCKA_INCLUDE (set by PKG_CHECK) v3: repair conflict with commit 7473f326366fbceb CMOCKA_INCLUDE is not correct, must be CMOCKA_CFLAGS (see config.status) Signed-off-by: Gert Doering <gert@greenie.muc.de> Acked-by: David Sommerseth <davids@openvpn.net> Message-Id: <20190623183210.6005-1-gert@greenie.muc.de> URL: https://www.mail-archive.com/openvpn-devel@lists.sourceforge.net/msg18570.html Signed-off-by: Gert Doering <gert@greenie.muc.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a4dbb34..439120e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,7 +53,7 @@ BUILT_SOURCES = \
config-version.h
endif
-SUBDIRS = build distro include src sample doc vendor tests
+SUBDIRS = build distro include src sample doc tests
dist_doc_DATA = \
README \